Чертежник рисует узор

КуМир

Разберём несколько примеров использования циклов при составлении алгоритмов для исполнителя Чертежник.

Цикл с параметром

Задача 1. Составим алгоритм для исполнителя Чертежник, который начертит на рабочем поле следующий рисунок.

узор чертежник

Для начала посмотрим на изображение и проанализируем его.  Центральный квадрат раздвигается относительно своего центра и делится на четыре части. Они повторяются с одинаковым шагом удаляясь от центра фигуры.

Для решения поставленной задачи потребуется применить цикл с параметром. Где в качестве параметра будет использоваться переменная величина, задающая шаг раздвижения квадрата.

Алгоритм:

использовать Чертежник
алг узор
нач цел х
  нц для х от 0 до 3
   опустить перо
   сместиться на вектор (-2,0)
   сместиться на вектор (0,2)
   поднять перо
   сместиться на вектор (0,х*2)
   опустить перо
   сместиться на вектор (0,2)
   сместиться на вектор (2,0)
   поднять перо
   сместиться на вектор (х*2,0)
   опустить перо
   сместиться на вектор (2,0)
   сместиться на вектор (0,-2)
   поднять перо
   сместиться на вектор (0,-х*2)
   опустить перо
   сместиться на вектор (0,-2)
   сместиться на вектор (-2,0)
   поднять перо
   сместиться на вектор (-х*2-1,-1)
  кц
кон

Рекомендуем: как настроить координатную плоскость исполнителя

Задача 2. Составим алгоритм для исполнителя Чертежник, который начертит на рабочем поле следующий рисунок.

 чертежник узор кумир

 

Также как и в предыдущей задаче потребуется применить цикл с параметром. Где в качестве параметра будет использоваться переменная величина, задающая шаг раздвижения знака.

Алгоритм:

использовать Чертежник
алг узор2
нач цел х
  нц для х от 0 до 3
   опустить перо
   сместиться на вектор (2,0)
   сместиться на вектор (0,2)
   поднять перо
   сместиться на вектор (х*2+1,0)
   опустить перо
   сместиться на вектор (0,-2)
   сместиться на вектор (2,0)
   поднять перо
   сместиться на вектор (0,-х*2-1)
   опустить перо
   сместиться на вектор (-2,0)
   сместиться на вектор (0,-2)
   поднять перо
   сместиться на вектор (-х*2-1,0)
   опустить перо
   сместиться на вектор (0,2)
   сместиться на вектор (-2,0)
   поднять перо
   сместиться на вектор (-1,2*х+2)
  кц
кон

Рекомендуем: как установить Кумир на ваш компьютер

Цикл N раз

Задача 3. Составить алгоритм для исполнителя Чертежник, который начертит на рабочем поле следующий узор.

узор для чертежника

 

В этой задаче потребуется применить цикл N раз и вспомогательный алгоритм. Вспомогательный алгоритм рисует маленький перечеркнутый квадрат. В основном алгоритме этот квадрат воспроизводится 25 раз (5 строк по 5 квадратов)

Алгоритм:

использовать Чертежник
алг узор
нач
  нц 5 раз
   нц 5 раз
    узор_1
   кц
   сместиться на вектор (-10,-2)
  кц
кон
алг узор_1
нач 
 опустить перо
 сместиться на вектор (0,2)
 сместиться на вектор (2,0)
 сместиться на вектор (0,-2)
 сместиться на вектор (-2,0)
 сместиться на вектор (0,2)
 сместиться на вектор (2,-2)
 сместиться на вектор (-2,0)
 сместиться на вектор (2,2)
 сместиться на вектор (0,-2)
 поднять перо
кон

Рекомендуем: основные команды исполнителя Чертежник 

Задача 3. Составьте алгоритм рисования узора, показанного на рисунке.

рисунок с узором

Алгоритм:

использовать Чертежник
алг узор
нач
 нц 4 раз
  нц 4 раз
   ромб
  кц
  сместиться на вектор (-8,-2)
 кц
кон
алг ромб
нач 
  опустить перо
  сместиться на вектор (1,1)
  сместиться на вектор (1,-1)
  сместиться на вектор (-1,-1)
  сместиться на вектор (-1,1)
  поднять перо
  сместиться на вектор (2,0)
кон

Рекомендуем: все уроки для исполнителя Чертежник в среде Кумир

Дополнительное задание 3: Составьте алгоритм, по которому Чертежник нарисует ряд из 5 квадратов. Самый маленький квадрат имеет размеры 1х1. У каждого следующего сторона увеличивается на 1 клетку.

ряд квадратов

Решение:

Код программы защищен

Под заголовком этой статьи указана рубрика. Перейдите в нее. Последнее слово в описании рубрики - КОДОВОЕ СЛОВО. Вставьте его в поле ниже и без пробела добавьте к нему номер задания.

Дополнительное задание 4: Составьте алгоритм, по которому Чертежник нарисует спираль, которая начинает раскручиваться из начала координат. Витки спирали отстоят на одну клетку друг от друга. Смотрите рисунок.

спираль чертеж

Решение:

Код программы защищен

Под заголовком этой статьи указана рубрика. Перейдите в нее. Последнее слово в описании рубрики - КОДОВОЕ СЛОВО. Вставьте его в поле ниже и без пробела добавьте к нему номер задания.

Рейтинг
( 2 оценки, среднее 5 из 5 )
Понравилась статья? Поделиться с друзьями:
Комментарии: 2
  1. Егор

    Что означает код программы защищен и зачем скрывать его? Как посмотреть программу.

    1. Сергей Фомин (автор)

      Егор, скрытие кода программы сделано намеренно, чтобы ты включил голову и подумал, как ее написать. Простое списывание не даст тебе понимания работы Чертежника. Ну, а, если уж никак не получается, то выполни указание с подсказкой и получишь код доступа к решению. Удачи!

Добавить комментарий

1 × 3 =

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!:

Adblock
detector